Delays with handling advanced routing.
Incident Report for Swrve - US
Resolved
This incident has been resolved.
Posted May 16, 2020 - 02:16 UTC
Investigating
We're investigating delays with handling advanced routing.
Posted May 16, 2020 - 01:37 UTC
This incident affected: Advanced Rule Processing.