Dashboard timeouts. US.
Incident Report for Swrve
Resolved
This incident has been resolved.
Posted Feb 27, 2020 - 19:03 UTC
Identified
We are continuing to see Dashboard performance issues and are implementing a further fix.
Posted Feb 27, 2020 - 17:40 UTC
This incident affected: Dashboard and Export API.